KamoCRM

IMAP/SMTP接続テストはネットワークプローブとして使用できません

FixEmailService
出荷済み
2026年9月23日 7:50 UTC
プロフィール
Kamo
コンテンツ
10784ec

POST /api/email/member-imap/test と /{id}/imap/test はどのホストに接続し、どのホストにも移植します。 caller は、生の例外メッセージを送信し、返します。 認証されたメンバーは、 クラスター・インテルナル・インフラストラクチャー — Redis、別のPod、Kubernetes API — で、 そこに聴いたものを指紋に戻って来た正確な言葉遣い(再使用、タイムアウト、リセット)、 一度に1つのホスト:「私のメール設定をテスト」ボタンから完全に構築されたポートスキャナー。 ImapConnectionTester は、両方のホストを解決し、いずれかのソケットが開く前に拒否します: ループバック、 RFC 1918およびキャリア等級NAT (100.64.0.0/10) IPv4の範囲、リンクローカル、マルチキャスト、未指定、 IPv6 fc00::7 独自のローカル レンジ (Java の isSiteLocalAddress() は、古い、非推奨の認識のみ fec0::/10 なので、ULA は独自のチェックが必要でした)、ドットレスのシングルラベル名、Kubernetes' ************************ 接尾辞は、すべて同じ、ジェネリックで拒否されます "Couldは、そのホストに接続しない" - すべての拒否は同じ読みます、従って、発信者はもはや言うことができません DNS の名前から内部 /8 からの内部のループバックは決して答えません。 ホストがSAVEDである前に同じガードが実行されます。これはテストされる前にのみです。 PUT と PersonalMailboxService#saveImap — テストボタンをスキップするメンバーがまだ持っているので これらの設定は、後日バックグラウンドの同期、タイマーでダイヤルされ、テスト結果は誰も読みません。 メニュー ********************と2つのテストを追加 PersonalMailboxServiceTest は変更なしで失敗します。プライベート レンジのホストは現在接続しています(または) 削除されるのではなく、現在報告されたエラーは実際にあったものによって異なる 他の端に耳を傾けます.

すべての変更

配送を見るのが好きですか?

自分のワークスペースに到着します。 無料プランをスタートし、月に再度このページをお読みください.

永遠に無料で始める料金を見る