KamoCRM

RecipientDomainValidator'da bulunan incelemenin üç yanlış yolu kapatın

FixEmailService
Shiked
29 Eylül 2026 02:05 UTC
Yazar
Kamo
Commit
38cd3d5

D-luna-1'in bağımsız incelemesi (email-fix-gang-1.md) iki BLOCKER ve bir MAJOR bulundu. Her bir gerçek yanlış yasal postanın reddedilmesi, bu koddan zaten bunu gösterdi Repo: - Case (BLOCKER): AliasService.createAlias, SharedMailboxService.create and **************** Tüm bir adres tam olarak bir yönetici olarak devam ediyor Doğru bir satır "Sat@kamocrm.com" okuyabilirsiniz. Her görünüm şimdi Veritabanına (LOWER(col) = LOWER(?) karşılaştırıldığında veyag id tarafından ele alındı. Hala bu organizasyonun her masanın kendi sıralarına ulaşıyor (org id HASH, col) Trans-organizasyon taraması yerine eşsiz indeks - sadece indeksin kullanımını kullanamaz Onlar içinde tam değeri aramak için sıralanmış dizi bileşeni. Fonksiyonel bir indeks üzerinde LOWER(col) masa başına (veya bu üç hizmette zaman yazma durumunda normalleştirme) Düz bir bakış açısı geri getirecekti; burada oturum açmadan ne yapılır, çünkü Her ikisi de bu görevden daha büyük. EntityManager yerel sorgular aracılığıyla uygulama Yeni kamo-shared-library repository yöntemlerinden ziyade recipientDomainValidator. - Plus-tags (BLOCKER): sage+urgent@kamocrm.com şimdi sage@kamocrm.com'a geçiyor. (EmailAddress.baseLocalPart(), aynı katlanılabilirlik / reression tabakası Posta kutusu kontrolü öncesinde zaten geçerlidir - birlias kontrolü için asla, çünkü bir çek için Alias kendi ayrı, kasıtlı olarak yaratılan adresidir. - Birden çok kök alanı (MAJOR): bir alias-domain adresi (kamouniverse.com) şimdi ************'deki her alana karşı yeniden katkıda bulunun UI varsayılan (önemliDomain) - ikinci sahip bir kök üzerinde posta kutusu artık okumaz Bilinmeyen olarak, çünkü org'un varsayılan alanı değil. - Deneyimsiz üye arama (MAJOR): ÜyeRepository geri çekilme kaldırıldı. **************** indeksi desteklememiş, bu yüzden bir tarama koştu Her gerçekten kötü tahmin için organizasyondaki her üye sıra - tam olarak bu özellik var olmak için kendi nedeni. Aynı zamanda gereksizdi: bu sınıf sadece her zaman çalışır KamoMail'de bir organizasyon için, gerçek, teslim edilebilir bir adres her zaman sahip olduğu **************** sıra (bu, hangi hükümlerin ne olduğunu gösterir); bir üye .email maç başına geliyor ama bu satırların hiçbiri posta kutusu yok Paylaşılan sunucu da, bu yüzden onlara bir gönderi RCPT'de başarısız olur, bu ne olursa olsun bunun için check dedi. Tam tartışma için sınıf javadoc'u görün. - Truncation (NIT): ************ Şimdi 5'te prosesını kaplar Adımlar (ve N daha fazla), bu yüzden DownstreamErrors' 300-char kesim artık yok e-bad-recipient, MailPack'in daha önce orta-address'dan mesaj gönderiyor Rehberlik ipucu kaldırıldı. reddedildiRecipients() asla ihlal edilmez. MINOR (existence oracle) bulmak, bir kod değişikliği değil, bir kod değişikliği olarak kabul edilir: Pre-flight check cevapları "does x@ownDomain var" önceden mevcut olandan daha hızlı SendFailedException->422 RECIPIENTS REJECTED yolu zaten (gerçek bir RCPT TO) olabilir, çünkü Aynı-org, koltuklu çağrıcı; yeni ayrıcalık sınırı açmaz. Testler (kırmızı doğrulandı, sonra yeşil): RecipientDomainValidatorTest yeniden yazıldı Yeni EntityManager tabanlı tasarım (mirrors **************************** RETURNS SELF Sorgu alayı) depolamak için yeni vakalarla, bir +tag Gerçek bir posta kutusuna karşı, hala çözemediği bir +tag ve bir alias-domain adresi adresi adresi adresi Gerçek posta kutusu olmayan bir kök domain üzerinde yaşıyor (bir ve olmadan birlikte) +tag). SendFailureResponseTest, capped prose vs için vaka kazandı. yapılandırılmış liste. ağır mvn testi ******************** 77 koşmak, 0 başarısızlık.

Tüm değişiklikler

Kargoyu gördüğünüz gibi?

Tüm bunlar kendi başına iş alanınıza geliyor. Ücretsiz plana başlayın ve bu sayfayı bir ay içinde tekrar okuyun.

Sonsuza Kadar Ücretsiz BaşlangıçFırsatları Görüntüle